Server Bug Reports and Feature Requests

A forum dedicated to the open-world survival game 7 Days to Die
Post Reply
Stevo
Site Admin
Site Admin
User avatar
Posts: 8546
Joined: Sun Oct 22, 2006 10:01 pm
Location: Orange County, CA
Minecraft name: StevoTVR
Blizzard tag: StevoTVR#1894
Contact:

Games Played

Ville Awards

Stevo.TVR’s avatar
Loading…

Server Bug Reports and Feature Requests

Post by Stevo » Thu Jan 10, 2019 6:03 pm

Our 7DtD server is running a custom management mod called SevenMod that is currently under early development. Since it is under development, there may be bugs or missing features. This thread is for reporting bugs or requesting features.

If you have a GitHub account, you can create an issue directly instead of posting here.

You can view the source code at https://github.com/SevenMod.

Bug Reports
  • Try to make sure the bug is related to the mod and not the game itself.
  • Be as descriptive as possible. Provide enough information for someone else to reproduce the problem.
Feature Requests
  • Describe the feature with as much detail as possible.
  • Provide justification. Why do you think the feature would be beneficial?
Thanks for your feedback. :)

Julie Ann Kaine
New Villun
New Villun
Posts: 3
Joined: Wed Mar 06, 2019 11:32 am

Re: Server Bug Reports and Feature Requests

Post by Julie Ann Kaine » Wed Mar 06, 2019 12:21 pm

Hello,

I've been enjoying your 7 Days to Die server for a few months or so now and am grateful for your hosting service. Hence it is with regret that I logged in here today to notify you of a consistent enough bug that seems either unique to your 7 Days to Die instance or rare enough that neither I nor the friends I frequently play with have experienced this bug on the other servers we've frequented.

In short, sections of our base get replaced with new terrain, possibly the original map terrain. This has happened to us twice now.

In length, these sections of terrain are not merely replaced, but are superimposed over the changes we made to the area. For example, while most of our generators were replaced with dirt/stone/gravel, the spinner traps that are connected to them via a Motion Sensor still function when triggered, even though they appear to have been replaced with the aforementioned dirt/stone/gravel. You can even hear the engines running, and are presumably still consuming the gasoline we filled them with.

This happened at a base of ours once before with the last build before this reset, and now it has happened again.

We also noticed this happen before the reset to a section of road we had cut through a mountain. This section of road was fine for weeks to a month or so, then a few hours before the section of our base was replaced, I noticed this section of road had appeared to revert back to its original state.

My best theory is that this glitch happens more frequently than we are aware, as this glitch might be linked with game code to reset Points of Interest (POI), such as when you trigger a quest or when the game resets loots or zombie respawns. But because this effect is unintended, it behaves in unexpected and undesired ways.

I also suspect that this may have something to do with the way your 7 Days to Die instance is configured, based solely on not hearing of this issue on any of the other servers my friends and I have frequented.

In any case, if TheVille can leverage some admin powers to help us reconstruct our base I would really appreciate it. And of course, if you could investigate this rather enjoyment-deflating bug in hopes of actually fixing it/re-mediating it I would be simply overjoyed!

Thank you!

Julie Ann Kaine
New Villun
New Villun
Posts: 3
Joined: Wed Mar 06, 2019 11:32 am

Re: Server Bug Reports and Feature Requests

Post by Julie Ann Kaine » Wed Mar 06, 2019 3:44 pm

Okay, does not appear to be specific to TheVille's instance.
https://7daystodie.com/forums/showthrea ... -Rewriting

Boss Llama
Server Ops
Server Ops
User avatar
Posts: 9733
Joined: Mon Mar 24, 2008 12:45 pm

Games Played

Ville Awards

<eVa>Boss Llama’s avatar
Loading…

Re: Server Bug Reports and Feature Requests

Post by Boss Llama » Wed Mar 06, 2019 4:13 pm

JAK - I'm sorry to hear that happened YET AGAIN. This is such an infuriating thing, and having it happen over and over to your group in particular is just sickening.

I will be on later tonight, and will gladly admin back in anything lost, and will help rebuild.
-Boss Llama

Julie Ann Kaine
New Villun
New Villun
Posts: 3
Joined: Wed Mar 06, 2019 11:32 am

Re: Server Bug Reports and Feature Requests

Post by Julie Ann Kaine » Thu Mar 07, 2019 5:47 pm

I was thinking that if the scheduled reboots happened only once per day instead of twice, there would be 50% less chance of problems from this bug since it only occurs when the game server service loads.

Stevo
Site Admin
Site Admin
User avatar
Posts: 8546
Joined: Sun Oct 22, 2006 10:01 pm
Location: Orange County, CA
Minecraft name: StevoTVR
Blizzard tag: StevoTVR#1894
Contact:

Games Played

Ville Awards

Stevo.TVR’s avatar
Loading…

Re: Server Bug Reports and Feature Requests

Post by Stevo » Thu Mar 07, 2019 5:51 pm

Julie Ann Kaine wrote:
Thu Mar 07, 2019 5:47 pm
I was thinking that if the scheduled reboots happened only once per day instead of twice, there would be 50% less chance of problems from this bug since it only occurs when the game server service loads.
Yeah, I got rid of the noon restart.

mylix
New Villun
New Villun
User avatar
Posts: 2
Joined: Sat Oct 13, 2018 2:45 pm

Re: Server Bug Reports and Feature Requests

Post by mylix » Tue Mar 12, 2019 1:36 pm

ok small bug i died and lost my stuff in 10minutes i thought u had 30 minutes to get stuff not 10 minutes this is bs.

Inner
Server Admin
Server Admin
Posts: 1353
Joined: Fri Dec 17, 2010 10:38 pm
Location: North Carolina

Games Played

Ville Awards

=USV= Inner’s avatar
Loading…

Re: Server Bug Reports and Feature Requests

Post by Inner » Tue Mar 12, 2019 8:43 pm

mylix wrote:
Tue Mar 12, 2019 1:36 pm
ok small bug i died and lost my stuff in 10minutes i thought u had 30 minutes to get stuff not 10 minutes this is bs.
I did some science around this. Emptied my backpack to just some junk and killed my self. It's still there after 2 hours, including a log off and log on. So it's probably not that your backpack 'timed out' but more likely something else happened. I've heard zombies stepping on packs can destroy them but I've never witnessed that.

Sedition
New Villun
New Villun
User avatar
Posts: 2
Joined: Tue May 28, 2019 1:20 am

Re: Server Bug Reports and Feature Requests

Post by Sedition » Tue May 28, 2019 2:15 pm

Having a bug on the 7 days server. My friend moved his claim block over about 10 spaces, so my other friend can place his claim next to it to cover the area we need, but the server still acts like its still in the old place. We can't place the new claim where we need it. It wont even let us place the new claim in the spot where his was even if his is destroyed and logged off. Maybe a server restart will fix it?

Stevo
Site Admin
Site Admin
User avatar
Posts: 8546
Joined: Sun Oct 22, 2006 10:01 pm
Location: Orange County, CA
Minecraft name: StevoTVR
Blizzard tag: StevoTVR#1894
Contact:

Games Played

Ville Awards

Stevo.TVR’s avatar
Loading…

Re: Server Bug Reports and Feature Requests

Post by Stevo » Tue May 28, 2019 2:26 pm

We can try restarting the server when it isn't quite so full.

FYI, any player can use /voterestart to start a server restart vote.

Inner
Server Admin
Server Admin
Posts: 1353
Joined: Fri Dec 17, 2010 10:38 pm
Location: North Carolina

Games Played

Ville Awards

=USV= Inner’s avatar
Loading…

Re: Server Bug Reports and Feature Requests

Post by Inner » Tue May 28, 2019 7:13 pm

Problem resolved. A claim that was thought to be removed, wasn't. That prevented the placement of a new claim block in that area. Once the original claim was removed, the new block was successfully placed.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest